IPv6 Fundamentals - PowerPoint PPT Presentation

Loading...

PPT – IPv6 Fundamentals PowerPoint presentation | free to view - id: 18edc-MzgwZ



Loading


The Adobe Flash plugin is needed to view this content

Get the plugin now

View by Category
About This Presentation
Title:

IPv6 Fundamentals

Description:

IPv6 Fundamentals. Original s thanks to: Abilene NOC at ... Smallville. ISP1 (uunet) ISP2 (AARNet) 2001:897::/35. 2001:388::/32. 2001:388:1210::/48 ... – PowerPoint PPT presentation

Number of Views:109
Avg rating:3.0/5.0
Slides: 51
Provided by: apan
Category:

less

Write a Comment
User Comments (0)
Transcript and Presenter's Notes

Title: IPv6 Fundamentals


1
IPv6 Fundamentals
  • Original slides thanks to
  • Abilene NOC at Indiana University
  • Grover Browning (gcbrowni_at_iu.edu)
  • Brent Sweeny (sweeny_at_iu.edu)
  • Modified by John Barlow for AARNet

2
V6 Fundamentals
  • IPv6 Basics
  • Network Configuration
  • Lab

3
IPv4 Subnet Masking
  • 10.10.10.1 /8 (bits of network)
  • 10.10.10.1 /16
  • 10.10.10.1 /24
  • 10.10.10.1 /28

4
IPv6 Subnet Masking
  • 20010468110034211234123412341234/64
  • 20010468110034211234123412341234/48
  • 20010468110034211234123412341234/40

5
IPv6 Prefixes
  • Subnet Masking, VLSM, Aggregation
  • 2001468/28
  • 20010468000000000000000000000000
  • 2001468ff00/48
  • 20010468ff0000000000000000000000
  • 2001468FF001052/64
  • 20010468ff0001050000000000000002

6
IPv6 Prefixes
  • Address Allocations
  • 2001388/32 AARNet
  • 2001388400/43 NT RNO
  • 2001388402/48 NTU
  • 2001388401b/64 My Subnet
  • 2001388401b1/128 My Machine

7
IPv6 Prefixes
  • 2001388/32
  • 2001388/43
  • 2001388/48
  • 2001388/64
  • 2001388/128

8
IPv6 Interfaces
  • Multiple Addresses per interface
  • Scope
  • Stateless Autoconfiguration

9
IPv6 Interfaces
  • Multiple Addresses per Interface
  • FE80230A3FFFEC681C
  • 2001388FF5441

10
Router Configuration
  • Rule 1 What Would v4 do?
  • (what do you need to do to enable v4 routing?)
  • Turn On Routing
  • Configure Interfaces
  • Configure Routing Protocols

11
Cisco Configs
  • ipv6 unicast-routing (Global)
  • ipv6 enable (Interface)
  • ipv6 (Interface)

12
Cisco Interface Config
  • auconf t
  • au(config)ipv6 unicast-routing
  • au(config)int tunnel 23
  • au(config-if)ipv6 enable
  • au(config-if)ipv6 address 2001388100011/64
  • au(config)int Ethernet 0
  • au(config-if)ipv6 enable
  • au(config-if)ipv6 address 2001388100021/64
  • Remember use /64 if you want autoconfigure to
    work!

13
Cisco Routing Config
  • Requires working IGP, for the lab we use directly
    connected interface addresses.
  • Router bgp
  • Address-family ipv6 unicast
  • Neighbor remote-as
  • Network 20013881000/48

14
Cisco Routing Config
  • Static route
  • ipv6 route
  • e.g. ipv6 route 20013881000/48 Null0 250
  • (to make sure you know the route so you can
    advertise it!)
  • BGP Prefix-filtering (at your upstream facing
    you)
  • ipv6 prefix-list From-Cairns permit
    2001388400/40
  • And to apply it
  • (bgp)neighbor 2001388100022 prefix-list
    From-Cairns in

15
Cisco - Tunnel
  • interface Tunnel1
  • description IPv6 tunnel to NSW RNO
  • ipv6 enable
  • ipv6 address 2001388052/64
  • tunnel source Loopback0
  • tunnel destination 192.231.212.5
  • tunnel mode ipv6ip

16
Cisco ATM PVC
  • interface ATM2/0.3 point-to-point
  • description Indiana Gigapop
  • pvc Indiana 3/66
  • ubr 155000
  • encapsulation aal5snap
  • ipv6 enable
  • ipv6 address 2001468FF5441/64

17
Cisco - Ethernet
  • interface FastEthernet2/0.51
  • description Dept. of pencil allocations
  • encapsulation dot1Q 51
  • ipv6 enable
  • ipv6 address 2001388401331/64

18
The Cisco Show
  • show ipv6 interface ! show all v6 address etc.
  • show bgp sum ! show summary of neighbors BGP
    state
  • show bgp ! show all v6 BGP-learned routes
  • show bgp neigh addr routes ! what hes sending
  • show bgp neigh addr advertised ! what youre
    sending
  • show ipv6 route ! show all v6 routes

19
Juniper
  • InGig edit interface at-1/2/0 unit 1
  • InGig edit family inet6
  • InGig set address 2001388ff5442/64
  • InGig edit routing-options rib-groups
  • InGig edit IF6-RG6
  • InGig set import-rib inet6.0

20
Juniper
  • routing-options
  • inet6.0
  • static
  • rib-group IF6-RG6
  • route 200146804000/40
  • reject
  • install
  • readvertise

21
set protocols bgp family inet6 any
group IUPUI6 type external
import From-IUPUI6 family inet6
any
peer-as 10680 neighbor
200146843f12 description
"IUPUI campus v6"
22
Juniper ATM PVC
  • at-1/2/0
  • description "to Border 1010 4/1/0"
  • enable
  • encapsulation atm-pvc
  • atm-options
  • vpi 3 maximum-vcs 128
  • unit 1
  • description "to IUPUI campus v6 router"
  • encapsulation atm-snap
  • point-to-point
  • vci 3.68
  • family inet6
  • address 200146843f11/64

23
Juniper Neighbor Advertisement
  • Protocols
  • Router-advertisement
  • Int fe1/1/1
  • Prefix 2001388/24

24
LAB 1
  • !!!Test Your Might!!!

25
IPv4 Basics
  • /30s for point-to-point interfaces
  • IPv4 IGP to get them talking to each other
  • Router ospf 1
  • net 0.0.0.0 255.255.255.255 area 0
  • check can you see/reach all other routers?

26
AARNet 192.231.212.5 2001388051/64
192.94.209.0/24 (.1 is default)
Cairns AS65500
.21
.17
.25
.22
.18
Darwin AS65100
Broome AS65200
.33
.29
.30
.26
.34
Alice AS65300
Doomadgee AS65530
Bourke AS65400
links use /30 ipv4
27
Then add IPv6
  • Plan
  • Allocate addresses to your dependent(s) LAN
  • Configure v6 on router
  • Turn ipv6 on globally
  • Add addresses to interfaces (point-to-point, LAN)
  • Add to exterior routing protocol
  • Filter if necessary
  • Check your work
  • What routes are you sending? Receiving?
  • Do you see all local IPv6 nets?
  • Do you see workshop IPv6 nets?
  • Do you see IPv6 internet? (300 prefixes)

28
Add v6 addresses
20013881c00/40
AARNet 192.231.212.5 2001388051/64
Cairns AS65500
20013881c00/40
X/64
X/64
X/64
X/64
X/64
X/64
Darwin AS65100
Broome AS65200
X/64
X/64
X/ZZ
X/ZZ
X/64
X/64
X/64
X/64
X/64
Alice AS65300
Doomadgee AS65530
Bourke AS65400
X/64
X/64
X/ZZ
X/ZZ
X/ZZ
X/64
29
Lab 1
  • Your turn!

30
Surfing IPv6
  • http//www.kame.net -- The kame or turtle at
    the top of the main page dances if you are
    connected via IPv6
  • http//ipv6.research.microsoft.com -- Accessible
    only via IPv6
  • Others?

31
IPv6 The Horror Within
  • Simplified Headers
  • Chained Heads
  • Traffic Types
  • Scope
  • Autoconfiguration
  • Multihoming Issues

32
Simplified Headers
V6 (40 bytes)
V4 (20 bytes)
33
Chained Headers
  • Hop-by-Hop Options
  • Routing Header
  • Fragment Header
  • Authentication Header
  • Encrypted Security Payload Header
  • Destination Options Header (Jumbo!)

34
Traffic Types
  • Unicast
  • Multicast
  • Anycast
  • Aiiiieeeee! Where did Broadcast go?

35
ICMP Types
  • 1 Destination Unreachable
  • 2 Packet Too Big
  • 3 Time Exceeded
  • 4 Parameter Problem
  • 128 Echo Request
  • 129 Echo Reply
  • 130 - Group Membership Query
  • 131 Group membership Report
  • 132 Group Membership Reduction
  • 133 Router Solicitation
  • 134 Router Advertisement
  • 135 Neighbor Solicitation
  • 136 Neighbor Advertisement
  • 137 - Redirect

36
Special Unicast Addresses
  • Unspecified address
  • All zeros ()
  • Used as source address during initialization
  • Also used in representing default
  • Loopback address
  • Low-order one bit (1)
  • Same as 127.0.0.1 in IPv4

37
Predefined Scopes
  • FE80/64 Link Scope
  • FEC/10 Site Scope (cf 10.0.0.0/8)
  • FF01 Node Scope
  • FF02 Link Scope
  • FF05 Site Scope
  • FF08 Organization Scope
  • FF0E Internet Scope

38
Stateless AutoConfiguration
  • Only works with /64!
  • Build a Link Local Address (Split MAC address,
    put FFFE in Middle.)
  • Join All Nodes Multicast Group (FF021)
  • Send Solicitation ICMP to All Routers (FF022)
    HOP set to 255.
  • Router responds with a Router Advertisement ICMP.
  • Prefixes have a Valid lifetime and a Preferred
    Lifetime.

39
Multihoming Issues
  • Punching Holes
  • Longest Prefix
  • Source Address Issues
  • Provider Independent Addressing

40
Multihoming
2001897/35
2001388/32
ISP1 (uunet)
ISP2 (AARNet)
University of Smallville
20013881210/48
20018970456/48
41
Provider-independent Multihoming
2001897/35
2001388/32
ISP1 (uunet)
ISP2 (AARNet)
20013881210/48
20018970456/48
University of Smallville
153423583456/48
42
PI Multihoming
152886532800/39
ISP2 (WestCo)
ISP1 UUnet
IBM 15288653294C/48
SOX 1528865328FE/48
Ford 1528865329A6/48
GE 152886532905/48
43
Campus/Gigapop IPv6
  • IOS Versions
  • Topology Issues
  • DNS Support
  • Traffic

44
Router software versions
  • Juniper 5.1 Line Rate v6
  • Cisco 12.2T (7x00, 3600, etc)
  • Cisco 12.0(19 or more)ST (GSR Only)
  • Router Support

45
Topology Issues
  • Inserting V6 into a production network

46
Layer-2 Campus1 Switch
Bldg Switch
Big Core Switch
Bldg Switch
Bldg Switch
Big Core Router
47
Layer-2 Campus1 Switch
Bldg Switch
Big Core Switch
Bldg Switch
Bldg Switch
Big Core Router
Small Core V6 Router
48
Layer-2 Campus2 Core Switches
Bldg Switch
Bldg Switch
Bldg Switch
Big Core Switch
Big Core Switch
Big Core Router
Big Core Router
49
Layer-2 Campus2 Core Switches
Bldg Switch
Bldg Switch
Bldg Switch
Small Core V6 Router
Big Core Switch
Big Core Switch
Big Core Router
Big Core Router
50
Layer-3 Campus
Bldg Router
Big Core Router
Bldg Router
Bldg Router
Border Router
51
Routing Protocols
  • The Role of BGP the IGP (RipNG / IS-IS)
  • Static Routing

52
DNS Issues
  • BIND Versions
  • v8 for ipv6 address support, v9 for dual-stack
  • Dual-Stack Support
  • Production System Support
  • Separate (experimental?) v6 DNS servers?

53
Equipment Needs
  • For a simple campus ipv6 implementation
  • One Router (Cisco 2600) 4,000
  • One Linux Box (DNS etc) 2,000
  • Or it could all be combined in a single PC with
  • Linux or BSD
  • Zebra (BGP routing)
  • DNS etc.

54
Future Needs
  • Routers V6 Support
  • Servers Dual-Stack, Code Revs
  • Topology Border/Core Designs

55
Abilene v6 Traffic
  • Not much..
  • See http//monon.uits.iupui.edu/abilene/ipv6/index
    .html

Abilene Indianapolis Aggregate IPv6 traffic
6/20/2002
56
Where are the applications?
  • bread-and-butter apps
  • telnet
  • ftp
  • http
  • Sendmail, various pop/imap clients (one that
    works for win32 is postie, from
    http//www.infradig.com/infradig/download.shtml)
  • dns/bind
  • nntp (news)
  • ssh
  • Also
  • Pchar
  • Netperf
  • A growing list

57
Contacts
  • AARNet IPv6 documentation
  • http//www.aarnet.edu.au/network/design/ipv6/
  • Australian mailing list
  • subscribe ipv6-au to ipv6-au-request_at_e-secure.c
    om.au
  • AARNet IPv6 working group see John Barlow
  • Internet2 IPv6 Working Group
  • http//ipv6.internet2.edu/
  • Your local RNO representative.
About PowerShow.com